re = /\/home\/user\/([^\/]+)/
str = '/home/user
/home/user/
/home/user/foo
/home/user/bar/foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end