re = /^S.*, [^S].*$/m
str = 'Schmidt, Paul
Sells, Simon
Smith, Peter
Stephens, Sheila'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end