#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(car|bus|bike|cycle)(?!\s+sold)"
Local $sString = "S.no Vehicle Status" & @CRLF & _
"1 car sold" & @CRLF & _
"2 bus not sold" & @CRLF & _
"3 bike sold" & @CRLF & _
"4 cycle Repair" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(?!foo) Negative Lookahead Asserts that what immediately follows the current position in the string is not foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")