import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(car|bus|bike|cycle)(?!\\s+sold)";
final String string = "S.no Vehicle Status\n"
+ "1 car sold\n"
+ "2 bus not sold\n"
+ "3 bike sold\n"
+ "4 cycle Repair\n\n\n"
+ "(?!foo) Negative Lookahead Asserts that what immediately follows the current position in the string is not foo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}