#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\*|[[:digit:]]{1,9})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:alpha:]]){3}[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]];[[:blank:]][[:print:]]*$"
Local $sString = "PS : This is some examples :" & @CRLF & _
"" & @CRLF & _
"* * * * * * * ; command" & @CRLF & _
"0 00 00 Mon 00 00 00 ; command" & @CRLF & _
"123456789 00 00 Mon 00 00 00 ; command" & @CRLF & _
"" & @CRLF & _
"01234556789 00 00 Mon 00 00 00 ; command" & @CRLF & _
"0 00 00 0 00 00 00 ; command" & @CRLF & _
"0 0 0 Mon 0 0 0 ; command"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")