$re = '/^(\*|[[:digit:]]{1,9})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:alpha:]]){3}[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]](\*|[[:digit:]]{2})[[:blank:]];[[:blank:]][[:print:]]*$/m';
$str = 'PS : This is some examples :
* * * * * * * ; command
0 00 00 Mon 00 00 00 ; command
123456789 00 00 Mon 00 00 00 ; command
01234556789 00 00 Mon 00 00 00 ; command
0 00 00 0 00 00 00 ; command
0 0 0 Mon 0 0 0 ; command';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);