#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Za-z0-9]{5,7}|(?=.{6,8}$)[A-Za-z0-9]+\s[A-Za-z0-9]+)$"
Local $sString = "A B144BA" & @CRLF & _
"A B144BA" & @CRLF & _
"AB 144BA" & @CRLF & _
"AB1 44BA" & @CRLF & _
"AB14 4BA" & @CRLF & _
"AB144 BA" & @CRLF & _
"AB144B A" & @CRLF & _
"AB1 4 4BA" & @CRLF & _
" ABCDE" & @CRLF & _
"ABCDE" & @CRLF & _
"ABCDE " & @CRLF & _
"ABC DE" & @CRLF & _
"ABCDEFGH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")