use strict;
my $str = 'A B144BA
A B144BA
AB 144BA
AB1 44BA
AB14 4BA
AB144 BA
AB144B A
AB1 4 4BA
ABCDE
ABCDE
ABCDE
ABC DE
ABCDEFGH';
my $regex = qr/^(?:[A-Za-z0-9]{5,7}|(?=.{6,8}$)[A-Za-z0-9]+\s[A-Za-z0-9]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}