const regex = /\b(?![a-z]+\b|\d+\b|\w*(\d)\w*\1)[a-z\d]+\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?![a-z]+\\b|\\d+\\b|\\w*(\\d)\\w*\\1)[a-z\\d]+\\b', 'gi')
const str = `I would like abc123 to match but not 123.
ab12s should also match
Only number-words like 1234 should not match
Words containing same numbers like ab22s should not match
234 should not match
hel1lo2haha3hoho4
hel1lo2haha3hoho3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}