re = /\b(?![a-z]+\b|\d+\b|\w*(\d)\w*\1)[a-z\d]+\b/i
str = 'I would like abc123 to match but not 123.
ab12s should also match
Only number-words like 1234 should not match
Words containing same numbers like ab22s should not match
234 should not match
hel1lo2haha3hoho4
hel1lo2haha3hoho3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end