const regex = /href="\/([^"]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="\\\/([^"]*)', 'gm')
const str = `<html>
<head>
<title>Hello</title>
</head>
<body>
<p>this is a simple text in html file</p>
<a href="https://google.com">Google</a>
<a href="/frontend/login/">Login</a>
<a href="/something/work/">Something</a>
</body>
</html>`;
const subst = `href="\/more\/\1additional`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);