#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:[A-Za-z]+-?)*)-in-((?:[A-Za-z]+-?)*)(?:\.[\w]{3,4})?"
Local $sString = "Sammi-Tye-in-Beauty.mp4" & @CRLF & _
"Sammi-Tye-in-Classic-Curves.mp4" & @CRLF & _
"Sammi-Tye-in-Classy-Erotica.mp4" & @CRLF & _
"Sammi-Tye-in-Classy-Erotica"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)