$re = '/^[a-zA-Z0-9$@!%*?&#^-_. +]+/m';
$str = 'This is a English Language
これは英語です
यह हिन्दी है ।
આ ગુજરાતી છે. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);