re = /^[a-zA-Z0-9$@!%*?&#^-_. +]+/m
str = 'This is a English Language
これは英語です
यह हिन्दी है ।
આ ગુજરાતી છે. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end