re = /\b([a-z]{1}[0-9]{4}|[a-z]{2}[0-9]{3}|[a-z]{3}[0-9]{2}|[a-z]{4}[0-9]{1})\b/m
str = 'Positive matches: a1111, aa111, aaa11, aaaa1
Negative matches: a1a1a, aa11a, aa11, 1aaaa '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end