re = /\d{1,3}(\.|,)\d+/m
str = '38.622446, -76.941988
53.545265,-113.486355
17.41586,78.48162
58,4272 15,6001
1234.4567.8910
1234-4567-8910
1234 4567 8910
1234 4567 8910.2 players ready
Cobalion-1234 4567 8910-3players waiting'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end