// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,3}(\.|,)\d+").unwrap();
let string = "38.622446, -76.941988
53.545265,-113.486355
17.41586,78.48162
58,4272 15,6001
1234.4567.8910
1234-4567-8910
1234 4567 8910
1234 4567 8910.2 players ready
Cobalion-1234 4567 8910-3players waiting";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}