package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:\d{1,3}[[:punct:]]){3,4}(?:\d{1,5})`)
var str = `123(123(123)123:27000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}