import re
regex = re.compile(r"(?:\d{1,3}[[:punct:]]){3,4}(?:\d{1,5})", flags=re.MULTILINE | re.IGNORECASE)
test_str = "123(123(123)123:27000"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")