package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\([(\d))]{2}\)\s?[(\d)]{4,5}+\-+[(\d)]{4})`)
var str = `(11)1234-1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}