const regex = /^[\u0370-\u03ff\u1f00-\u1fff]+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\u0370-\\u03ff\\u1f00-\\u1fff]+$', '')
const str = `χρήμα`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}