$re = '/This is a sequence ((?:(?!\.\s).)*)/m';
$str = 'This is a sequence of nothing. This is another
This is a sequence of nothing this is another';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);