re = /This is a sequence ((?:(?!\.\s).)*)/m
str = 'This is a sequence of nothing. This is another
This is a sequence of nothing this is another'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end