package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s+[A-Z\-]{2,6}[\.\n]?\s+`)
var str = `the cat is DEAD `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}