$re = '/\s+[A-Z\-]{2,6}[\.\n]?\s+/';
$str = 'the cat is DEAD ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);