using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",{2,}";
string input = @",Metrics_Count,Device_UID,Command_Name,Command_Interval,,Instance_UID,,Metrics_Size_KB,,,Tags_Countfrom command_execution,,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}