package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),{2,}`)
var str = `,Metrics_Count,Device_UID,Command_Name,Command_Interval,,Instance_UID,,Metrics_Size_KB,,,Tags_Countfrom command_execution,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}