const regex = /([^\/]+)(?=\/[^\/]+$)|(\w+)(?=[ ).-])|(\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\/]+)(?=\\\/[^\\\/]+$)|(\\w+)(?=[ ).-])|(\\w+)$', 'gm')
const str = `
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file.txt
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file - Copy.txt
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file (1).txt
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file - Copy (2).txt
C:/User/Name/Folder/Subfolder1/fileB.txt
C:/User/Name/Folder/file.C.txt
C:/User/Name/Folder/file-D.txt
C:/User/Name/Folder/file`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}