$re = '/([^\/]+)(?=\/[^\/]+$)|(\w+)(?=[ ).-])|(\w+)$/m';
$str = '
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file.txt
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file - Copy.txt
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file (1).txt
C:/User/Name/Folder/Subfolder1/Sub-subfolder/file - Copy (2).txt
C:/User/Name/Folder/Subfolder1/fileB.txt
C:/User/Name/Folder/file.C.txt
C:/User/Name/Folder/file-D.txt
C:/User/Name/Folder/file';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);