package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d\d?(?:\.\d\d?)?cm$`)
var str = `80cm
80.2cm
80.25cm
71-80cm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}