$re = '/^\d\d?(?:\.\d\d?)?cm$/m';
$str = '80cm
80.2cm
80.25cm
71-80cm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);