$re = '/Android \d+; ([^;]+) Build/i';
$str = 'Android 13; SM-A515F Build/
Linux; Android 10; LM-K510 Build/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);