$re = '/^[A-z\d_@.#$=!%^)(\]:\*;\?\/\,}{\'\|<>\[&\+-]*$/m';
$str = 'test
test123
test-(132
test|\'^@)=&#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);