re = /^[A-z\d_@.#$=!%^)(\]:\*;\?\/\,}{'\|<>\[&\+-]*$/m
str = 'test
test123
test-(132
test|\'^@)=&#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end