$re = '/^[a-zA-Z]:(\\\\[^\:\\\\]+)\\\\[a-z-A-Z]ystem32\\\\[a-z-A-Z]md.exe/m';
$str = 'c:\\Windows\\system32\\Cmd.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);