#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\bABC\s)(?!.*\bABC\b).*"
Local $sString = "ABC anything about the sky ABC and anything about the moon" & @CRLF & _
"ABC anything about the sky ABC and anything ABC about the moon" & @CRLF & _
"ABC anything about the sky ABC and anything about the moon ABC test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")