using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bABC\s)(?!.*\bABC\b).*";
string input = @"ABC anything about the sky ABC and anything about the moon
ABC anything about the sky ABC and anything ABC about the moon
ABC anything about the sky ABC and anything about the moon ABC test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}