package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-([0-9-]*)-`)
var str = `num-12345678-num
num-12345678-234-213-num`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}