$re = '/-([0-9-]*)-/';
$str = 'num-12345678-num
num-12345678-234-213-num';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);