#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)-?(?:[_a-z]|[^\0-\177]|\\[0-9a-f]{1,6}(\r\n|[ \n\r\t\f])?|\\[^\n\r\f0-9a-f])(?:[_a-z0-9-]|[^\0-\177]|\\[0-9a-f]{1,6}(\r\n|[ \n\r\t\f])?|\\[^\n\r\f0-9a-f])*"
Local $sString = "123class" & @CRLF & _
"-1-1-a" & @CRLF & _
"--class" & @CRLF & _
"1-class" & @CRLF & _
"-class" & @CRLF & _
"-🍕-slice" & @CRLF & _
"🍕-slice" & @CRLF & _
"a" & @CRLF & _
"1" & @CRLF & _
"_class" & @CRLF & _
"_1class" & @CRLF & _
"___" & @CRLF & _
"--1" & @CRLF & _
"--a" & @CRLF & _
"UPPercas" & @CRLF & _
"_Up-Per" & @CRLF & _
"-UPPERCASE" & @CRLF & _
"--UPercase"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")