$re = '/-?(?:[_a-z]|[^\0-\177]|\\\\[0-9a-f]{1,6}(\r\n|[ \n\r\t\f])?|\\\\[^\n\r\f0-9a-f])(?:[_a-z0-9-]|[^\0-\177]|\\\\[0-9a-f]{1,6}(\r\n|[ \n\r\t\f])?|\\\\[^\n\r\f0-9a-f])*/mi';
$str = '123class
-1-1-a
--class
1-class
-class
-🍕-slice
🍕-slice
a
1
_class
_1class
___
--1
--a
UPPercas
_Up-Per
-UPPERCASE
--UPercase';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);