$re = '/\/f\/.+?(?=page)/m';
$str = 'https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/page/2/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);