re = /\/f\/.+?(?=page)/m
str = 'https://dev.site.by/catalog/vinilovoe-pokryitie/f/example/page/2/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end