import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https|ftp|sftp):\\/\\/(www\\.)*(\\w\\.)*\\w+\\.(\\w){1,3}(:\\d{1,4})*(\\/*)[a-zA-Z0-9_.?&= %]*";
final String string = "http://google.com\n"
+ "https://www.google.com\n"
+ "http://www.google.com/search\n"
+ "ftp://test.test.example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}