re = /(http|https|ftp|sftp):\/\/(www\.)*(\w\.)*\w+\.(\w){1,3}(:\d{1,4})*(\/*)[a-zA-Z0-9_.?&= %]*/m
str = 'http://google.com
https://www.google.com
http://www.google.com/search
ftp://test.test.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end