package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*([^.].{3}|.[^m].{2}|.{2}[^a].|.{3}[^p])|.{0,3})$`)
var str = `abc
app.yaml
app.mapa
app.map
app.123.map`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}