re = /^(.*([^.].{3}|.[^m].{2}|.{2}[^a].|.{3}[^p])|.{0,3})$/m
str = 'abc
app.yaml
app.mapa
app.map
app.123.map'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end