using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*).*""(.*)"".*;\s(.*).*;\s(.*)";
string input = @"текст текст; ""текст в двойных кавычках; текст в двойных кавычках; текст в двойных кавычках""; текст; текст";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}