re = /(.*).*"(.*)".*;\s(.*).*;\s(.*)/
str = 'текст текст; "текст в двойных кавычках; текст в двойных кавычках; текст в двойных кавычках"; текст; текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end