package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d{3,4}\s*)?\D{2}(\s*\d{3,4})?`)
var str = `AD0200
PQ 200
sk 0315
0300AD
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}